CVE Feed

    Dashboard / CVE / CVE-2026-82806

    CVE-2026-82806

    Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

    Published:Oct 1, 2026
    Last Modified:Oct 1, 2026
    EPS:Oct 1, 2026
    EPSS Score:
    CVSS Score:5.3

    Affected Products

    Vendor
    Apache
    Product
    Apache Apisix

    Exploits

    No exploit reference

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High