CVE-2026-86247
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Published:Sep 23, 2026
Last Modified:Oct 6, 2026
EPS:Sep 23, 2026
EPSS Score:0.00179
CVSS Score:7.4
Affected Products
Vendor
Product
Action
Vendor
Apache
Product
Apache Tomcat
Apache
Apache Tomcat
Vendor
Apache
Product
Tomcat Native
Apache
Tomcat Native
Exploits
No exploit reference
Common Weakness Enumeration
Common Attack Pattern Enumeration and Classification (CAPEC)
Related CVEs
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
