CVE Feed

    Dashboard / CVE / CVE-2026-94212

    CVE-2026-94212

    Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

    Published:Oct 1, 2026
    Last Modified:Oct 1, 2026
    EPS:Oct 1, 2026
    EPSS Score:
    CVSS Score:6.4

    Affected Products

    Vendor
    Apache
    Product
    Apisix

    Exploits

    No exploit reference

    Common Attack Pattern Enumeration and Classification (CAPEC)

    Related CVEs

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High