AZL-112700
Dashboard / Vulnerabilities / AZL-112700
Summary: CVE-2026-61813 affecting package mod_security 2.9.7-8
Details: ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.
References: https://nvd.nist.gov/vuln/detail/CVE-2026-61813
Affected packages
Package
Name: mod_security
Purl: pkg:rpm/azure-linux/mod_security
Affected ranges
Type: ECOSYSTEM
Events:
