AZL-31610
Dashboard / Vulnerabilities / AZL-31610
Summary: CVE-2023-43622 affecting package httpd for versions less than 2.4.58-1
Details: An attacker, opening a HTTP/2 connection with an initial window size of 0, was able to block handling of that connection indefinitely in Apache HTTP Server. This could be used to exhaust worker resources in the server, similar to the well known "slow loris" attack pattern. This has been fixed in version 2.4.58, so that such connection are terminated properly after the configured connection timeout. This issue affects Apache HTTP Server: from 2.4.55 through 2.4.57. Users are recommended to upgrade to version 2.4.58, which fixes the issue.
References: https://nvd.nist.gov/vuln/detail/CVE-2023-43622
Affected packages
Package
Name: httpd
Purl: pkg:rpm/azure-linux/httpd
Affected ranges
Type: ECOSYSTEM
Events:
