AZL-44415
Dashboard / Vulnerabilities / AZL-44415
Summary: CVE-2015-1029 affecting package puppet for versions less than 7.34.0-1
Details: The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
References: https://nvd.nist.gov/vuln/detail/CVE-2015-1029
Affected packages
Package
Name: puppet
Purl: pkg:rpm/azure-linux/puppet
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -7.34.0-1
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
