BIT-dotnet-sdk-2026-111497

    Dashboard / Vulnerabilities / BIT-dotnet-sdk-2026-111497

    BIT-dotnet-sdk-2026-111497

    Published: 29 Oct 2026Last Modified: 5 Nov 2026

    Summary: Out-of-Bounds Write in Google Brotli Decoder

    Details: A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

    Affected packages

    Package

    Name: dotnet-sdk

    Purl: pkg:bitnami/dotnet-sdk

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 8.0.0
    Fixed -8.0.33

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High