BIT-gitlab-2022-3411
Dashboard / Vulnerabilities / BIT-gitlab-2022-3411
Summary:
Details: A lack of length validation in GitLab CE/EE affecting all versions from 12.4 before 15.6.7, 15.7 before 15.7.6, and 15.8 before 15.8.1 allows an authenticated attacker to create a large Issue description via GraphQL which, when repeatedly requested, saturates CPU usage.
References: https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3411.json, https://gitlab.com/gitlab-org/gitlab/-/issues/376247, https://hackerone.com/reports/1685995, https://nvd.nist.gov/vuln/detail/CVE-2022-3411
Affected packages
Package
Name: gitlab
Purl: pkg:bitnami/gitlab
Affected ranges
Type: SEMVER
Events:
Introduced- 12.4.0
Fixed -15.6.7
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
