BIT-gitlab-2023-5963
Dashboard / Vulnerabilities / BIT-gitlab-2023-5963
Summary: Allocation of Resources Without Limits or Throttling in GitLab
Details: An issue has been discovered in GitLab EE with Advanced Search affecting all versions from 13.9 to 16.3.6, 16.4 prior to 16.4.2 and 16.5 prior to 16.5.1 that could allow a denial of service in the Advanced Search function by chaining too many syntax operators.
References: https://gitlab.com/gitlab-org/gitlab/-/issues/423468, https://nvd.nist.gov/vuln/detail/CVE-2023-5963
Affected packages
Package
Name: gitlab
Purl: pkg:bitnami/gitlab
Affected ranges
Type: SEMVER
Events:
Introduced- 13.9.0
Fixed -16.3.6
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
