BIT-nginx-2022-41741

    Dashboard / Vulnerabilities / BIT-nginx-2022-41741

    BIT-nginx-2022-41741

    Published: 6 Mar 2024Last Modified: 10 Sept 2026

    Summary: NGINX ngx_http_mp4_module vulnerability CVE-2022-41741

    Details: NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.

    Affected packages

    Package

    Name: nginx

    Purl: pkg:bitnami/nginx

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 1.1.3
    Fixed -1.22.1

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    BIT-nginx-2022-41741 | CVE-DB