CVE-2022-36110

    Dashboard / Vulnerabilities / CVE-2022-36110

    CVE-2022-36110

    Published: 9 Sept 2022Last Modified: 21 Oct 2026

    Summary: Netmaker vulnerable to Insufficient Granularity of Access Control

    Details: Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

    Affected packages

    Package

    Name:

    Purl:

    Affected ranges

    Type: GIT

    Events:

    Affected versions

    v0.14.6
    v0.14.5
    v0.14.4
    v0.14.3
    v0.14.2
    v0.14.1
    v0.14.1-testing

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    CVE-2022-36110 | CVE-DB