CVE-2022-37734
Dashboard / Vulnerabilities / CVE-2022-37734
Summary:
Details: graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.
References: https://github.com/graphql-java/graphql-java/discussions/2958, https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/37xxx/CVE-2022-37734.json, https://nvd.nist.gov/vuln/detail/CVE-2022-37734, https://github.com/graphql-java/graphql-java/issues/2888, https://github.com/graphql-java/graphql-java/pull/2892, https://github.com/graphql-java/graphql-java/releases
Affected packages
Package
Name:
Purl:
Affected ranges
Affected versions
v17.3
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
