CVE-2022-39362

    Dashboard / Vulnerabilities / CVE-2022-39362

    CVE-2022-39362

    Published: 26 Oct 2022Last Modified: 28 Oct 2026

    Summary: Metabase vulnerable to arbitrary SQL execution from queryhash

    Details: Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, unsaved SQL queries are auto-executed, which could pose a possible attack vector. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer automatically executes ad-hoc native queries. Now the native editor shows the query and gives the user the option to manually run the query if they want.

    Affected packages

    Package

    Name:

    Purl:

    Affected ranges

    Type: GIT

    Events:

    Introduced- c529fe2f7a6be48354fedd8f36c940b787bafa2d

    Affected versions

    v1.41.8
    v1.41.7
    v1.41.6
    v1.41.5
    v1.41.3.1
    v1.41.3
    v1.41.2
    v1.41.1
    v1.41.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    CVE-2022-39362 | CVE-DB