CVE-2024-24574

    Dashboard / Vulnerabilities / CVE-2024-24574

    CVE-2024-24574

    Published: 5 Feb 2024Last Modified: 28 Oct 2026

    Summary: phpMyFAQ vulnerable to stored XSS on attachments filename

    Details: phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.

    Affected packages

    Package

    Name:

    Purl:

    Affected ranges

    Type: GIT

    Events:

    Affected versions

    3.2.4
    3.2.3
    3.2.2
    3.2.1
    3.2.0
    3.2.0-RC.4
    3.2.0-RC.2
    3.2.0-RC
    3.2.0-beta.2
    3.2.0-beta
    3.2.0-alpha

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    CVE-2024-24574 | CVE-DB