CVE-2026-112899
Dashboard / Vulnerabilities / CVE-2026-112899
Summary: Pillow: EPS load(scale) lets Ghostscript render past the decompression bomb limit
Details: Pillow is a Python imaging library. In versions 2.3.0 through 12.3.0, EPS rendering does not validate the scaled image dimensions before invoking Ghostscript. Applications that process untrusted EPS or PostScript files using an application-selected scale greater than one can incur excessive Ghostscript CPU and temporary disk consumption. In versions with decompression-bomb protection, the scaled output is checked only after Ghostscript has completed rendering, allowing resource consumption beyond the configured pixel limit. The amplification depends on the scale selected by the application, not an attacker-controlled scale value. This issue is fixed in version 13.0.0.
References: https://github.com/python-pillow/Pillow/releases/tag/13.0.0, https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/112xxx/CVE-2026-112899.json, https://github.com/python-pillow/Pillow/security/advisories/GHSA-vx6w-vv9f-6gvg, https://nvd.nist.gov/vuln/detail/CVE-2026-112899, https://github.com/python-pillow/Pillow/commit/3e8cc105588d1dfe062fcada0b6058c1b5f14b65, https://github.com/python-pillow/Pillow/pull/10112
Affected packages
Package
Name:
Purl:
Affected ranges
Type: GIT
Events:
