CVE-2026-85076

    Dashboard / Vulnerabilities / CVE-2026-85076

    CVE-2026-85076

    Published: 5 Nov 2026Last Modified: 7 Nov 2026

    Summary: Cronicle: Privilege Escalation via Arbitrary Environment Variable Injection through Event Params (Incomplete Fix for CVE-2026-39401)

    Details: Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.124, an authenticated non-admin with run_events, create_events, or edit_events privilege can supply undeclared keys in event params through api_create_event, api_update_event, or api_run_event. lib/api.js and lib/api/event.js validate the parameter object without restricting its keys, and lib/job.js uppercases those keys and applies them to the child process environment after administrator-defined plugin variables. A key that collides with a security-sensitive environment variable can therefore override the plugin execution context and may cause privilege escalation, arbitrary code execution, data access, or service disruption depending on the plugin and runtime. This issue is fixed in version 0.9.124.

    Affected packages

    Package

    Name:

    Purl:

    Affected ranges

    Type: GIT

    Events:

    Affected versions

    v0.9.123
    v0.9.122
    v0.9.121
    v0.9.120
    v0.9.119
    v0.9.118
    v0.9.117
    v0.9.116
    v0.9.115
    v0.9.114
    v0.9.113
    v0.9.112
    v0.9.111
    v0.9.110
    v0.9.109
    v0.9.108
    v0.9.107
    v0.9.106
    v0.9.105
    v0.9.104
    v0.9.103
    v0.9.102
    v0.9.101
    v0.9.100
    v0.9.99
    v0.9.98
    v0.9.97
    v0.9.96
    v0.9.95
    v0.9.94
    v0.9.93
    v0.9.92
    v0.9.91
    v0.9.90
    v0.9.89
    v0.9.88
    v0.9.87
    v0.9.86
    v0.9.85
    v0.9.84
    v0.9.83
    v0.9.82
    v0.9.81
    v0.9.80
    v0.9.79
    v0.9.78
    v0.9.77
    v0.9.76
    v0.9.75
    v0.9.74
    v0.9.73
    v0.9.72
    v0.9.71
    v0.9.70
    v0.9.69
    v0.9.68
    v0.9.67
    v0.9.66
    v0.9.65
    v0.9.64
    v0.9.63
    v0.9.62
    v0.9.61
    v0.9.60
    v0.9.59
    v0.9.58
    v0.9.57
    v0.9.56
    v0.9.55
    v0.9.54
    v0.9.53
    v0.9.52
    v0.9.51
    v0.9.50
    v0.9.49
    v0.9.48
    v0.9.47
    v0.9.46
    v0.9.45
    v0.9.44
    v0.9.43
    v0.9.42
    v0.9.41
    v0.9.40
    v0.9.39
    v0.9.38
    v0.9.37
    v0.9.36
    v0.9.35
    v0.9.34
    v0.9.33
    v0.9.32
    v0.9.31
    v0.9.30
    v0.9.29
    v0.9.28
    v0.9.27
    v0.9.26
    v0.9.25
    v0.9.24
    v0.9.23
    v0.9.22
    v0.9.21
    v0.9.20
    v0.9.19
    v0.9.18
    v0.9.17
    v0.9.16
    v0.9.15
    v0.9.14
    v0.9.13
    v0.9.12
    v0.9.11
    v0.9.10
    v0.9.9
    v0.9.8
    v0.9.7
    v0.9.6
    v0.9.5
    v0.9.4
    v0.9.3
    v0.9.2
    v0.9.1
    v0.9.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    CVE-2026-85076 | CVE-DB