DEBIAN-CVE-2014-3483

    Dashboard / Vulnerabilities / DEBIAN-CVE-2014-3483

    DEBIAN-CVE-2014-3483

    Published: 7 Jul 2014Last Modified: 23 Oct 2026
    Upstream:

    Summary:

    Details: SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

    Affected packages

    Package

    Name: rails

    Purl: pkg:deb/debian/rails?arch=source&distro=bookworm

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2:4.1.4-1

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    DEBIAN-CVE-2014-3483 | CVE-DB