DEBIAN-CVE-2023-49295
Dashboard / Vulnerabilities / DEBIAN-CVE-2023-49295
Summary:
Details: quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Affected packages
Package
Name: golang-github-lucas-clemente-quic-go
Purl: pkg:deb/debian/golang-github-lucas-clemente-quic-go?arch=source&distro=bookworm
Affected ranges
Type: ECOSYSTEM
Events:
