GHSA-32wr-qqw6-5mfp

    Dashboard / Vulnerabilities / GHSA-32wr-qqw6-5mfp

    GHSA-32wr-qqw6-5mfp

    Published: 14 Oct 2023Last Modified: 13 Feb 2025

    Summary: Apache Airflow vulnerable to sensitive information exposure

    Details: Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user with access to read specific DAGs _only_ to read information about task instances in other DAGs. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

    Affected packages

    Package

    Name: apache-airflow

    Purl: pkg:pypi/apache-airflow

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.7.2

    Affected versions

    1.10.0
    1.10.1
    1.10.10
    1.10.10rc1
    1.10.10rc2
    1.10.10rc3
    1.10.10rc4
    1.10.10rc5
    1.10.11
    1.10.11rc1
    1.10.11rc2
    1.10.12
    1.10.12rc1
    1.10.12rc2
    1.10.12rc3
    1.10.12rc4
    1.10.13
    1.10.13rc1
    1.10.14
    1.10.14rc1
    1.10.14rc2
    1.10.14rc3
    1.10.14rc4
    1.10.15
    1.10.15rc1
    1.10.1b1
    1.10.1rc2
    1.10.2
    1.10.2b2
    1.10.2rc1
    1.10.2rc2
    1.10.2rc3
    1.10.3
    1.10.3b1
    1.10.3b2
    1.10.3rc1
    1.10.3rc2
    1.10.4
    1.10.4b2
    1.10.4rc1
    1.10.4rc2
    1.10.4rc3
    1.10.4rc4
    1.10.4rc5
    1.10.5
    1.10.5rc1
    1.10.6
    1.10.6rc1
    1.10.6rc2
    1.10.7
    1.10.7rc1
    1.10.7rc2
    1.10.7rc3
    1.10.8
    1.10.8rc1
    1.10.9
    1.10.9rc1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-32wr-qqw6-5mfp | CVE-DB