GHSA-337m-mw94-2v6g

    Dashboard / Vulnerabilities / GHSA-337m-mw94-2v6g

    GHSA-337m-mw94-2v6g

    Published: 14 May 2026Last Modified: 10 Sept 2026

    Summary: Apache Commons Configuration: StackOverflowError for YAML input with cycles

    Details: Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

    Affected packages

    Package

    Name: org.apache.commons:commons-configuration2

    Purl: pkg:maven/org.apache.commons/commons-configuration2

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 2.2
    Fixed -2.15.0

    Affected versions

    2.10.0
    2.10.1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High