GHSA-373r-9mg8-3jc4
Dashboard / Vulnerabilities / GHSA-373r-9mg8-3jc4
Summary: Apache Geode vulnerable to Cross-Site Scripting
Details: Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.
References: https://nvd.nist.gov/vuln/detail/CVE-2022-34870, https://github.com/apache/geode, https://lists.apache.org/thread/zltlr7f2ymr2m6jj54k4z0c4foos5fwx, http://www.openwall.com/lists/oss-security/2022/10/24/3
Affected packages
Package
Name: org.apache.geode:geode-core
Purl: pkg:maven/org.apache.geode/geode-core
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -1.15.1
Affected versions
1.0.0-incubating
1.0.0-incubating.M2
1.0.0-incubating.M3
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
