GHSA-3hwc-rqwp-v36q

    Dashboard / Vulnerabilities / GHSA-3hwc-rqwp-v36q

    GHSA-3hwc-rqwp-v36q

    Published: 9 Feb 2024Last Modified: 13 Feb 2025

    Summary: Apache Solr can leak certain passwords due to System Property redaction logic inconsistencies

    Details: Insufficiently Protected Credentials vulnerability in Apache Solr. This issue affects Apache Solr from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0. One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name. There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint. This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI. This /admin/info/properties endpoint is protected under the "config-read" permission. Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission. Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue. A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps". By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password". Users who cannot upgrade can also use the following Java system property to fix the issue:   `-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*`

    Affected packages

    Package

    Name: org.apache.solr:solr-core

    Purl: pkg:maven/org.apache.solr/solr-core

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 6.0.0
    Fixed -8.11.3

    Affected versions

    6.0.0
    6.0.1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-3hwc-rqwp-v36q | CVE-DB