GHSA-4mp7-2m29-gqxf
Dashboard / Vulnerabilities / GHSA-4mp7-2m29-gqxf
GHSA-4mp7-2m29-gqxf
Published: 31 Jan 2024Last Modified: 16 Sept 2024
Summary: HashiCorp Vault Authentication bypass
Details: HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
References: https://nvd.nist.gov/vuln/detail/CVE-2020-16251, https://github.com/hashicorp/vault, https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151, https://www.hashicorp.com/blog/category/vault, http://packetstormsecurity.com/files/159479/Hashicorp-Vault-GCP-IAM-Integration-Authentication-Bypass.html
Affected packages
Package
Name: github.com/hashicorp/vault
Purl: pkg:golang/github.com/hashicorp/vault
Affected ranges
Type: SEMVER
Events:
Introduced- 0.8.3
Fixed -1.2.5
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
