GHSA-4wxw-42wx-2wfx

    Dashboard / Vulnerabilities / GHSA-4wxw-42wx-2wfx

    GHSA-4wxw-42wx-2wfx

    Published: 9 Feb 2024Last Modified: 6 Dec 2024

    Summary: Apache Solr Schema Designer blindly "trusts" all configsets

    Details: Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue.

    Affected packages

    Package

    Name: org.apache.solr:solr-core

    Purl: pkg:maven/org.apache.solr/solr-core

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 9.0.0
    Fixed -9.3.0

    Affected versions

    9.0.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-4wxw-42wx-2wfx | CVE-DB