GHSA-564r-hj7v-mcr5

    Dashboard / Vulnerabilities / GHSA-564r-hj7v-mcr5

    GHSA-564r-hj7v-mcr5

    Published: 23 Mar 2023Last Modified: 25 Feb 2025

    Summary: Spring Framework vulnerable to denial of service via specially crafted SpEL expression

    Details: In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

    Affected packages

    Package

    Name: org.springframework:spring-expression

    Purl: pkg:maven/org.springframework/spring-expression

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 6.0.0
    Fixed -6.0.7

    Affected versions

    6.0.0
    6.0.1
    6.0.2
    6.0.3
    6.0.4
    6.0.5
    6.0.6

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-564r-hj7v-mcr5 | CVE-DB