GHSA-5v3h-fjv2-54fg

    Dashboard / Vulnerabilities / GHSA-5v3h-fjv2-54fg

    GHSA-5v3h-fjv2-54fg

    Published: 29 Jun 2026Last Modified: 4 Nov 2026

    Summary: Apache Tomcat has an Improper Authorization vulnerability

    Details: Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

    Affected packages

    Package

    Name: org.apache.tomcat.embed:tomcat-embed-core

    Purl: pkg:maven/org.apache.tomcat.embed/tomcat-embed-core

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 11.0.0-M1
    Fixed -11.0.23

    Affected versions

    11.0.0
    11.0.0-M1
    11.0.0-M10
    11.0.0-M11
    11.0.0-M12
    11.0.0-M13
    11.0.0-M14
    11.0.0-M15
    11.0.0-M16
    11.0.0-M17
    11.0.0-M18
    11.0.0-M19
    11.0.0-M20
    11.0.0-M21
    11.0.0-M22
    11.0.0-M24
    11.0.0-M25
    11.0.0-M26
    11.0.0-M3
    11.0.0-M4
    11.0.0-M5
    11.0.0-M6
    11.0.0-M7
    11.0.0-M9
    11.0.1
    11.0.10
    11.0.11
    11.0.12
    11.0.13
    11.0.14
    11.0.15
    11.0.18
    11.0.2
    11.0.20
    11.0.21
    11.0.22
    11.0.3
    11.0.4
    11.0.5
    11.0.6
    11.0.7
    11.0.8
    11.0.9

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-5v3h-fjv2-54fg | CVE-DB