GHSA-666g-rfc5-c9jv

    Dashboard / Vulnerabilities / GHSA-666g-rfc5-c9jv

    GHSA-666g-rfc5-c9jv

    Published: 28 Oct 2023Last Modified: 13 Jul 2026

    Summary: Apache Airflow Celery provider Insertion of Sensitive Information into Log File vulnerability

    Details: Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.

    Affected packages

    Package

    Name: apache-airflow-providers-celery

    Purl: pkg:pypi/apache-airflow-providers-celery

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 3.3.0
    Fixed -3.4.1

    Affected versions

    3.3.0
    3.3.1
    3.3.1rc1
    3.3.2
    3.3.2rc1
    3.3.3
    3.3.3rc1
    3.3.4
    3.3.4rc1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-666g-rfc5-c9jv | CVE-DB