GHSA-66hv-fhcm-7xm7

    Dashboard / Vulnerabilities / GHSA-66hv-fhcm-7xm7

    GHSA-66hv-fhcm-7xm7

    Published: 25 Oct 2023Last Modified: 16 Feb 2024

    Summary: Jenkins Warnings Plugin exposures system-scoped credentials

    Details: Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing the use of system-scoped credentials otherwise reserved for the global configuration. This allows attackers with Item/Configure permission to access and capture credentials they are not entitled to. Warnings Plugin 10.5.1 defines the appropriate context for credentials lookup. This fix has been backported to 10.4.1.

    Affected packages

    Package

    Name: io.jenkins.plugins:warnings-ng

    Purl: pkg:maven/io.jenkins.plugins/warnings-ng

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 10.5.0
    Fixed -10.5.1

    Affected versions

    10.5.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-66hv-fhcm-7xm7 | CVE-DB