GHSA-6hr3-44gx-g6wh

    Dashboard / Vulnerabilities / GHSA-6hr3-44gx-g6wh

    GHSA-6hr3-44gx-g6wh

    Published: 13 Feb 2023Last Modified: 21 Mar 2025

    Summary: Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin

    Details: In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger Cross-site Scripting (XSS) by uploading a crafted .sql file through the drag-and-drop interface. By disabling the configuration directive `$cfg['enable_drag_drop_import']`, users will be unable to use the drag and drop upload which would protect against the vulnerability.

    Affected packages

    Package

    Name: phpmyadmin/phpmyadmin

    Purl: pkg:composer/phpmyadmin/phpmyadmin

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 4.3.0
    Fixed -4.9.11

    Affected versions

    4.7.0
    4.7.1
    4.7.2
    4.7.3
    4.7.4
    4.7.5
    4.7.6
    4.7.7
    4.7.8
    4.7.9

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-6hr3-44gx-g6wh | CVE-DB