GHSA-6mhr-52mv-6v6f

    Dashboard / Vulnerabilities / GHSA-6mhr-52mv-6v6f

    GHSA-6mhr-52mv-6v6f

    Published: 18 Oct 2022Last Modified: 8 Nov 2023

    Summary: Field-level access-control bypass for multiselect field

    Details: #### Impact `@keystone-6/[email protected] || 2.3.0` users who are using the `multiselect` field, and provided field-level access control - are vulnerable to their field-level access control not being used. List-level access control is **NOT** affected. Field-level access control for fields other than `multiselect` are **NOT** affected. Example, **you are vulnerable if** you are using field-level access control on a `multiselect` like the following: ```ts const yourList = list({ access: { // this is list-level access control, this is NOT impacted }, fields: { yourFieldName: multiselect({ // this is field-level access control, for multiselect fields // this is vulnerable access: { create: ({ session }) => session?.data.isAdmin, update: ({ session }) => session?.data.isAdmin, }, options: [ { value: 'apples', label: 'Apples' }, { value: 'oranges', label: 'Oranges' }, ], // ... }), // ... }, // ... }); ``` #### Mitigation Please upgrade to `@keystone-6/core >= 2.3.1`, where this vulnerability has been closed. #### Workarounds If for some reason you cannot upgrade your dependencies, you should stop using the `multiselect` field. #### Credits Thanks to [Marek R](https://github.com/marekryb) for reporting and submitting the pull request to fix this problem. If you have any questions around this security advisory, please don't hesitate to contact us at [[email protected]](mailto:[email protected]), or [open an issue on GitHub](https://github.com/keystonejs/keystone/issues/new/choose). If you have a security flaw to report for any software in this repository, please see our [SECURITY policy](https://github.com/keystonejs/keystone/blob/main/SECURITY.md).

    Affected packages

    Package

    Name: @keystone-6/core

    Purl: pkg:npm/%40keystone-6/core

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 2.2.0
    Fixed -2.3.1

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High