GHSA-99pc-69q9-jxf2

    Dashboard / Vulnerabilities / GHSA-99pc-69q9-jxf2

    GHSA-99pc-69q9-jxf2

    Published: 26 Oct 2023Last Modified: 13 Feb 2025

    Summary: Elasticsearch allows insertion of sensitive information into log files when using deprecated URIs

    Details: Elasticsearch generally filters out sensitive information and credentials before logging to the audit log. It was found that this filtering was not applied when requests to Elasticsearch use certain deprecated URIs for APIs. The impact of this flaw is that sensitive information such as passwords and tokens might be printed in cleartext in Elasticsearch audit logs. Note that audit logging is disabled by default and needs to be explicitly enabled and even when audit logging is enabled, request bodies that could contain sensitive information are not printed to the audit log unless explicitly configured. The `_xpack/security` APIs have been deprecated in Elasticsearch 7.x and were entirely removed in 8.0.0 and later. The only way for a client to use them in Elasticsearch 8.0.0 and later is to provide the `Accept: application/json; compatible-with=7` header. Elasticsearch official clients do not use these deprecated APIs. The list of affected, deprecated APIs, is the following: `POST /_xpack/security/user/{username}` `PUT /_xpack/security/user/{username}` `PUT /_xpack/security/user/{username}/_password` `POST /_xpack/security/user/{username}/_password` `PUT /_xpack/security/user/_password` `POST /_xpack/security/user/_password` `POST /_xpack/security/oauth2/token` `DELETE /_xpack/security/oauth2/token` `POST /_xpack/security/saml/authenticate`

    Affected packages

    Package

    Name: org.elasticsearch:elasticsearch

    Purl: pkg:maven/org.elasticsearch/elasticsearch

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 7.0.0
    Fixed -7.17.13

    Affected versions

    7.0.0
    7.0.1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-99pc-69q9-jxf2 | CVE-DB