GHSA-9cv5-4wqv-9w94

    Dashboard / Vulnerabilities / GHSA-9cv5-4wqv-9w94

    GHSA-9cv5-4wqv-9w94

    Published: 1 Nov 2022Last Modified: 8 Nov 2023

    Summary: muhammara and hummus vulnerable to denial of service by NULL pointer dereference

    Details: ### Impact The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. ### Patches It has been patched in 3.1.1 and has been backported to 2.6.1 Hummus has a patch in 1.0.111. ### Workarounds Do not process files from untrusted sources or update. ### References https://nvd.nist.gov/vuln/detail/CVE-2022-25892 https://github.com/galkahana/HummusJS/issues/463 https://github.com/julianhille/MuhammaraJS/issues/214 https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002 https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51 https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138 https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320

    Affected packages

    Package

    Name: muhammara

    Purl: pkg:npm/muhammara

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 0
    Fixed -2.6.1

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-9cv5-4wqv-9w94 | CVE-DB