GHSA-9j65-3f2q-8q2r

    Dashboard / Vulnerabilities / GHSA-9j65-3f2q-8q2r

    GHSA-9j65-3f2q-8q2r

    Published: 15 Feb 2023Last Modified: 16 Feb 2024

    Summary: Cross-site Scripting in Jenkins Pipeline: Build Step Plugin

    Details: Jenkins Pipeline: Build Step Plugin 2.18 and earlier does not escape job names in a JavaScript expression used in the Pipeline Snippet Generator, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control job names.

    Affected packages

    Package

    Name: org.jenkins-ci.plugins:pipeline-build-step

    Purl: pkg:maven/org.jenkins-ci.plugins/pipeline-build-step

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.18.1

    Affected versions

    2.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High