GHSA-9qj4-v6r6-3wmx

    Dashboard / Vulnerabilities / GHSA-9qj4-v6r6-3wmx

    GHSA-9qj4-v6r6-3wmx

    Published: 30 Jun 2026Last Modified: 4 Nov 2026

    Summary: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have a Denial of Service via Out of Memory vulnerability

    Details: Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7. Users are recommended to upgrade to version 6.2.7, which fixes the issue.

    Affected packages

    Package

    Name: org.apache.activemq:activemq-broker

    Purl: pkg:maven/org.apache.activemq/activemq-broker

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 5.19.7
    Fixed -5.19.8

    Affected versions

    5.19.7

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-9qj4-v6r6-3wmx | CVE-DB