GHSA-c3v2-5388-v8pw

    Dashboard / Vulnerabilities / GHSA-c3v2-5388-v8pw

    GHSA-c3v2-5388-v8pw

    Published: 15 Feb 2023Last Modified: 16 Feb 2024

    Summary: CSRF vulnerability in Jenkins Coverity Plugin allow capturing credentials

    Details: Missing permission checks in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

    Affected packages

    Package

    Name: org.jenkins-ci.plugins:synopsys-coverity

    Purl: pkg:maven/org.jenkins-ci.plugins/synopsys-coverity

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.0.3

    Affected versions

    1.0.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High