GHSA-cw2v-wv4g-w4p6

    Dashboard / Vulnerabilities / GHSA-cw2v-wv4g-w4p6

    GHSA-cw2v-wv4g-w4p6

    Published: 18 Sept 2022Last Modified: 25 Oct 2024

    Summary: rdiffweb CSRF vulnerability in admin area can lead to deletion of repositories and users

    Details: rdiffweb prior to 2.4.5 is vulnerable to Cross-Site Request Forgery (CSRF). An attacker exploiting this vulnerability can use it to delete repositories and users.

    Affected packages

    Package

    Name: rdiffweb

    Purl: pkg:pypi/rdiffweb

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.4.5

    Affected versions

    0.10.0
    0.10.2
    0.10.3
    0.10.4
    0.10.5
    0.10.6
    0.10.7
    0.10.8
    0.10.9

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High