GHSA-gcgw-q47m-prvj

    Dashboard / Vulnerabilities / GHSA-gcgw-q47m-prvj

    GHSA-gcgw-q47m-prvj

    Published: 12 Dec 2023Last Modified: 30 Nov 2024

    Summary: Duplicate Advisory: Improper JWT Signature Validation in SAP Security Services Library

    Details: ## Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-59c9-pxq8-9c73. This link is maintained to preserve external references. ## Original Description SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) - versions below 2.17.0 and versions from 3.0.0 to before 3.3.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.

    Affected packages

    Package

    Name: com.sap.cloud.security:java-security

    Purl: pkg:maven/com.sap.cloud.security/java-security

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.17.0

    Affected versions

    2.10.0
    2.10.1
    2.10.2
    2.10.3
    2.10.4
    2.10.5

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-gcgw-q47m-prvj | CVE-DB