GHSA-gvg3-83q4-rfhq

    Dashboard / Vulnerabilities / GHSA-gvg3-83q4-rfhq

    GHSA-gvg3-83q4-rfhq

    Published: 14 Feb 2023Last Modified: 8 Nov 2023

    Summary: Command injection in Apache Sling

    Details: Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

    Affected packages

    Package

    Name: org.apache.sling:org.apache.sling.jcr.base

    Purl: pkg:maven/org.apache.sling/org.apache.sling.jcr.base

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.1.12

    Affected versions

    2.0.2-incubator
    2.0.4-incubator
    2.0.6

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-gvg3-83q4-rfhq | CVE-DB