GHSA-h2rq-qhr7-53gm

    Dashboard / Vulnerabilities / GHSA-h2rq-qhr7-53gm

    GHSA-h2rq-qhr7-53gm

    Published: 6 Feb 2024Last Modified: 13 Feb 2025

    Summary: Apache Sling Servlets Resolver executes malicious code via path traversal

    Details: Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script.  Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.

    Affected packages

    Package

    Name: org.apache.sling:org.apache.sling.servlets.resolver

    Purl: pkg:maven/org.apache.sling/org.apache.sling.servlets.resolver

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.11.0

    Affected versions

    2.0.4-incubator
    2.0.6-incubator
    2.0.8

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High