GHSA-h792-v28v-ppgr
Dashboard / Vulnerabilities / GHSA-h792-v28v-ppgr
GHSA-h792-v28v-ppgr
Summary: Apache Tomcat's rewrite valve has an Always-Incorrect Control Flow Implementation vulnerability
Details: Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
References: https://nvd.nist.gov/vuln/detail/CVE-2026-53404, https://github.com/apache/tomcat/commit/b647cb584cea8bf95e64f5d2526c59ab8fca3225, https://github.com/apache/tomcat/commit/bbb6219fa5ac185060bef7842cee5fb90230ca00, https://github.com/apache/tomcat/commit/fe06ae8a71997061596f54189dae1b1b5da75430, https://github.com/apache/tomcat, https://lists.apache.org/thread/rdhpghgfskrdmw9hqzjgjrtw538smpmz, https://tomcat.apache.org/security-10.html, https://tomcat.apache.org/security-11.html, https://tomcat.apache.org/security-9.html, http://www.openwall.com/lists/oss-security/2026/06/29/21
Affected packages
Package
Name: org.apache.tomcat.embed:tomcat-embed-core
Purl: pkg:maven/org.apache.tomcat.embed/tomcat-embed-core
Affected ranges
Type: ECOSYSTEM
Events:
