GHSA-hwxf-qxj7-7rfj

    Dashboard / Vulnerabilities / GHSA-hwxf-qxj7-7rfj

    GHSA-hwxf-qxj7-7rfj

    Published: 30 Oct 2023Last Modified: 16 Feb 2024

    Summary: CodeIgniter4 vulnerable to information disclosure when detailed error report is displayed in production environment

    Details: ### Impact If an error or exception occurs in CodeIgniter4 v4.4.2 and earlier, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. ### Patches Upgrade to v4.4.3 or later. See [upgrading guide](https://codeigniter4.github.io/userguide/installation/upgrade_443.html). ### Workarounds Replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`. ### For more information If you have any questions or comments about this advisory: * Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues) * Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)

    Affected packages

    Package

    Name: codeigniter4/framework

    Purl: pkg:composer/codeigniter4/framework

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -4.4.3

    Affected versions

    4.0.0
    4.0.0-rc.4

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High