GHSA-jwr6-75xh-jh5j

    Dashboard / Vulnerabilities / GHSA-jwr6-75xh-jh5j

    GHSA-jwr6-75xh-jh5j

    Published: 15 Feb 2023Last Modified: 8 Nov 2023

    Summary: Synopsys Jenkins Coverity Plugin has Incorrect Default Permissions

    Details: Synopsys Coverity Plugin 3.0.2 and earlier does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Synopsys Coverity Plugin 3.0.3 requires the appropriate permissions.

    Affected packages

    Package

    Name: org.jenkins-ci.plugins:synopsys-coverity

    Purl: pkg:maven/org.jenkins-ci.plugins/synopsys-coverity

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.0.3

    Affected versions

    1.0.0

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High