GHSA-m678-f26j-3hrp

    Dashboard / Vulnerabilities / GHSA-m678-f26j-3hrp

    GHSA-m678-f26j-3hrp

    Published: 26 Oct 2022Last Modified: 15 Feb 2025

    Summary: Execution with Unnecessary Privileges in JupyterApp

    Details: ### Impact _What kind of vulnerability is it? Who is impacted?_ We’d like to disclose an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in the current working directory. This vulnerability allows one user to run code as another. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Users should upgrade to `jupyter_core>=4.11.2`. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ No ### References _Are there any links users can visit to find out more?_ Similar advisory in [IPython](https://github.com/advisories/GHSA-pq7m-3gw7-gq5x)

    Affected packages

    Package

    Name: jupyter-core

    Purl: pkg:pypi/jupyter-core

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -4.11.2

    Affected versions

    4.0.0
    4.0.0.dev
    4.0.1
    4.0.2
    4.0.3
    4.0.4
    4.0.5
    4.0.6

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-m678-f26j-3hrp | CVE-DB