GHSA-mw2w-2hj2-fg8q

    Dashboard / Vulnerabilities / GHSA-mw2w-2hj2-fg8q

    GHSA-mw2w-2hj2-fg8q

    Published: 14 Nov 2023Last Modified: 16 Feb 2024

    Summary: yiisoft/yii deserializing untrusted user input can lead to remote code execution

    Details: ### Impact Affected versions of `yiisoft/yii` are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. ### Patches Upgrade `yiisoft/yii` to version 1.1.29 or higher. ### For more information See the following links for more details: - [Git commit](https://github.com/yiisoft/yii/commit/37142be4dc5831114a375392e86d6450d4951c06) - https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection If you have any questions or comments about this advisory, [contact us through security form](https://www.yiiframework.com/security).

    Affected packages

    Package

    Name: yiisoft/yii

    Purl: pkg:composer/yiisoft/yii

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1.1.29

    Affected versions

    1.1.14
    1.1.14-rc
    1.1.15
    1.1.16
    1.1.17
    1.1.18
    1.1.19
    1.1.20
    1.1.21
    1.1.22
    1.1.23
    1.1.24
    1.1.25
    1.1.26
    1.1.27
    1.1.28

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-mw2w-2hj2-fg8q | CVE-DB