GHSA-p2fr-mq9m-6w6p

    Dashboard / Vulnerabilities / GHSA-p2fr-mq9m-6w6p

    GHSA-p2fr-mq9m-6w6p

    Published: 15 Feb 2023Last Modified: 16 Feb 2024

    Summary: Cross-site Scripting in Jenkins Email Extension Plugin

    Details: Jenkins Email Extension Plugin 2.93 and earlier does not escape, sanitize, or sandbox rendered email template output or log output generated during template rendering, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create or change custom email templates.

    Affected packages

    Package

    Name: org.jenkins-ci.plugins:email-ext

    Purl: pkg:maven/org.jenkins-ci.plugins/email-ext

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.94

    Affected versions

    2.11

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High