GHSA-r9cm-pw9j-3fpx

    Dashboard / Vulnerabilities / GHSA-r9cm-pw9j-3fpx

    GHSA-r9cm-pw9j-3fpx

    Published: 1 Nov 2023Last Modified: 3 Apr 2025

    Summary: Dolibarr Improper Input Validation vulnerability

    Details: Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.

    Affected packages

    Package

    Name: dolibarr/dolibarr

    Purl: pkg:composer/dolibarr/dolibarr

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -18.0.2

    Affected versions

    10.0.0
    10.0.1
    10.0.2
    10.0.3
    10.0.4
    10.0.5
    10.0.6
    10.0.7

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-r9cm-pw9j-3fpx | CVE-DB