GHSA-rwf9-8fqr-p44m

    Dashboard / Vulnerabilities / GHSA-rwf9-8fqr-p44m

    GHSA-rwf9-8fqr-p44m

    Published: 9 Jan 2024Last Modified: 21 Feb 2024
    Aliases:

    Summary: Qualys Jenkins Plugin for Policy Compliance Cross-site Scripting vulnerability

    Details: Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data.

    Affected packages

    Package

    Name: com.qualys.plugins:qualys-pc

    Purl: pkg:maven/com.qualys.plugins/qualys-pc

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1.0.6

    Affected versions

    1.0.0
    1.0.1
    1.0.2
    1.0.3
    1.0.4
    1.0.5

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High