GHSA-vpgf-fgm8-gxr2
Dashboard / Vulnerabilities / GHSA-vpgf-fgm8-gxr2
Summary: Apache DolphinScheduler vulnerable to Path Traversal
Details: Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
References: https://nvd.nist.gov/vuln/detail/CVE-2022-26884, https://github.com/apache/dolphinscheduler, https://github.com/apache/dolphinscheduler/releases/tag/2.0.6, https://lists.apache.org/thread/xfdst5y4hnrm2ntmc5jzrgmw2htyyb9c, http://www.openwall.com/lists/oss-security/2022/10/28/2
Affected packages
Package
Name: org.apache.dolphinscheduler:dolphinscheduler
Purl: pkg:maven/org.apache.dolphinscheduler/dolphinscheduler
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -2.0.6
Affected versions
1.2.0
1.2.1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
