GHSA-wr3m-gw98-mc3j

    Dashboard / Vulnerabilities / GHSA-wr3m-gw98-mc3j

    GHSA-wr3m-gw98-mc3j

    Published: 14 May 2022Last Modified: 8 Nov 2023
    Aliases:

    Summary: Improper Input Validation in Apache Tomcat

    Details: Apache Tomcat before 5.5.35, 6.x before 6.0.35, and 7.x before 7.0.23 computes hash values for form parameters without restricting the ability to trigger hash collisions predictably, which allows remote attackers to cause a denial of service (CPU consumption) by sending many crafted parameters.

    Affected packages

    Package

    Name: org.apache.tomcat:tomcat

    Purl: pkg:maven/org.apache.tomcat/tomcat

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 5.5.0
    Fixed -5.5.35

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-wr3m-gw98-mc3j | CVE-DB