GHSA-xj5v-6v4g-jfw6
Dashboard / Vulnerabilities / GHSA-xj5v-6v4g-jfw6
Summary: Rack has possible DoS Vulnerability with Range Header
Details: # Possible DoS Vulnerability with Range Header in Rack There is a possible DoS vulnerability relating to the Range request header in Rack. This vulnerability has been assigned the CVE identifier CVE-2024-26141. Versions Affected: >= 1.3.0. Not affected: < 1.3.0 Fixed Versions: 3.0.9.1, 2.2.8.1 Impact ------ Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the `Rack::File` middleware or the `Rack::Utils.byte_ranges` methods (this includes Rails applications). Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- There are no feasible workarounds for this issue. Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. * 3-0-range.patch - Patch for 3.0 series * 2-2-range.patch - Patch for 2.2 series Credits ------- Thank you [ooooooo_q](https://hackerone.com/ooooooo_q) for the report and patch
References: https://github.com/rack/rack/security/advisories/GHSA-xj5v-6v4g-jfw6, https://nvd.nist.gov/vuln/detail/CVE-2024-26141, https://github.com/rack/rack/commit/4849132bef471adb21131980df745f4bb84de2d9, https://github.com/rack/rack/commit/62457686b26d33a15a254c7768c2076e8e02b48b, https://discuss.rubyonrails.org/t/possible-dos-vulnerability-with-range-header-in-rack/84944, https://github.com/rack/rack, https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26141.yml
Affected packages
Package
Name: rack
Purl: pkg:gem/rack
Affected ranges
Type: ECOSYSTEM
Events:
